TLS Encryption Protocol Update

At Magnus Health we strive to stay on top of new technologies, including the latest and greatest security protocols. As such, we will soon upgrade our TLS encryption protocol to keep with industry standards and compliance.

Click here to view a Webinar Recording from our team full of information regarding this upgrade.

When will this change occur?
This will occur on March 16th, 2016 at 5am EST. We expect approximately one hour of downtime.
Who will be impacted by this upgrade?
Any person attempting to log into the Magnus Health Portal, parent/student/school user.
What does this change mean?
Magnus will discontinue the support of TLS1.0 on the https://secure.magnushealthportal.com site.

After this change, older browsers and devices that make an https:// connection will not be able to connect to Magnus Health via the site listed. Many browsers and devices are updated and thus it is very likely that there will be no impact to most of our users, but we encourage our users to confirm.

How do I know if my device is compatible with this change?
We want to make sure that you do not have any challenges accessing our portal.
Please use our TLS Tester to determine if you need to update your device.
You can share the following url with parents/students: http://testtls.mymagnus.com/
Sample Email to Parents
As of March 16, 2016, connecting to Magnus Health will require the use of browsers and devices that are compatible with the latest version of the Transport Layer Security protocol (TLS). Older browsers and devices that make an https:// connection will not be able to connect to Magnus Health. Many browsers and devices are updated and thus it is very likely that there will be no impact to your access. We want to make sure that you do not have any challenges accessing the parent portal.
Please use the TLS tester available at: http://testtls.mymagnus.com/
If you have any questions, please contact the Magnus Health Help Desk at 1-877-461-6831.
Mobile Devices
Browsers

Browsers known to support the latest version of TLS are as follows:

Programming Systems

Systems known to support the latest version of TLS are as follows: